Cameo Collaborator 18.0 SP1 Documentation

Skip to end of metadata
Go to start of metadata

Since Cameo Collaborator is based on Alfresco Community, you need to install and configure Alfresco Community to be able to use Cameo Collaborator.

To be ready for the installation, go to the Download Cameo Collaborator page and obtain the following files:

  • Alfresco Community 5.0.d installer.

    We highly recommend using this particular installer and have a fresh instance of Alfresco Community, even if you already use another instance of any Alfresco edition.

  • cameo-collaborator-share-<version number>.amp
  • cameo-collaborator-repo-<version number>.amp

 

To upgrade from Cameo Collaborator 18.0 Alpha or Alpha 2, you must uninstall Alfresco Community 5.0.a (configured for Cameo Collaborator 18.0 Alpha or Alpha 2) and install Alfresco Community 5.0.d and configure it for Cameo Collaborator 18.0 SP1 by following the steps of the instructions below. All projects and users from previous version will be unavailable in the new installation.

 

Before you start the installation, you must make sure the architecture meets the prerequisites for the Alfresco Community installation.

To validate the architecture, follow the steps described in Alfresco Community Documentation. Pay special attention to the Database validation step in order to ensure the prevention of the data loss due to database failure, when using Cameo Collaborator.

 

To install Alfresco Community and configure it for Cameo Collaborator


  1. Start Alfresco Community 5.0.d installer.
  2. In the Language Selection dialog, select English - English (if not yet selected) and click OK.
  3. In the first step of the Alfresco Community Setup Wizard, click Next.
  4. In the second step of the wizard, select Easy - Installs servers with the default configuration (if not yet selected) and click Next.
  5. In the third step of the wizard, select a folder to install Alfresco Community and click Next.
  6. In the fourth step of the wizard, type a password for the administrator account (for example, admin) and click Next.
  7. In the fifth step of the wizard, click Next to begin the installation.
  8. Wait until the installation is completed (this may take 1 to 15 minutes).
  9. In the final step of the wizard, clear all the check boxes in this case the server must be configured before launching!) and click the Finish button.



  10. Copy the cameo-collaborator-share-<version number>.amp file to <Alfresco Community installation directory>\amps_share, e.g., C:\Alfresco\amps_share.
  11. Copy the cameo-collaborator-repo-<version number>.amp file to <Alfresco Community installation directory>\amps, e.g., C:\Alfresco\amps.
  12. Open the Command Prompt window.

    Be sure you run the application as administrator.

  13. Go to the <Alfresco Community installation directory>\bin directory.



  14. At the command prompt, type apply_amps.bat and press Enter.

  15. Press Enter twice again when you are asked to.



  16. As the configuration is finished, you can close the command-line interface.

Now you can start the server.