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EXCEL IMPORT
1.  Getting Started
To start using Excel Import in MagicDraw, you need to (i) understand what Excel Import is, (ii) understand its 
key features, (iii) download it, and then (iv) start using it in MagicDraw. The purpose of the Getting Started 
section is to help you familiarize yourself with the Excel Import plugin as quickly as possible.

1.1 Introduction to Excel Import

The Excel Import plugin is an effective and useful tool, which is designed to allow you to import data or 
information from any Excel (.xls and .xlsx) or CSV (.csv and .txt) format files to MagicDraw and export data 
from a MagicDraw project into an Excel or a CSV file. The plugin works with MagicDraw version 18.0 and 
greater.

A typical spreadsheet or Excel file arranges numbers and text in numbered rows and letter-named columns. 
Data in these rows and columns may be in a form of line graphs, histograms, and charts, and with a very 
limited three-dimensional graphical display. However, only data organized in a simple spreadsheet style 
without graphs, histograms, charts, or graphics are importable into MagicDraw.

A comma-separated value or CSV file contains data in a form of numbers and text. A CSV file is a simple text 
file that consists of a sequence of characters or numbers called records. Each record is divided into fields and 
separated by delimiters such as a comma, semicolon, colon, or tab. These data are also transferrable into 
MagicDraw.

With Excel Import, you can import table headings from an Excel or a CSV file into MagicDraw as schema 
classes and import data in each row from the file as the instance specifications of the schema classes. The 
plugin can import composite headers as multiple schema classes.

Once imported, you can use Excel Import to map the schema class to a target element and create a class 
mapping that will be represented in a mapping diagram. You can also import data from an Excel or CSV file 
through the class mapping. However, the element the plugin will import varies according to the type of target 
element selected in the class mapping. Target elements that you can select are UML and SysML profiles, and 
a user model. 

The following are three possible types of elements resulting from importing data through a class mapping:

• If you select a target element type from a UML profile, the plugin will import data as the same 
element type in the UML meta model.

• If you select a target element type from a SysML profile, for example, a requirement or a block, 
the plugin will import data as the same element type in the SysML profile.

• If you select a target element type from a user model, for example, a class or a block, the plugin 
will import data as the instance specification of a user model.

You can also export the instance specifications or mapped elements into xls, xlsx, csv, or.txt format.

The Excel Import plugin supports:

(i) Excel file

• filename extensions .xls and .xlsx.

• importing multiple sheets in a file at a time.
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• table headings, rows, merged cells.

• composite headers (a table with multiple headings in a pyramid shape).

• boolean, text, and number data types.

Figure 1 -- A Table with Composite Headers

(ii) CSV file

• filename extensions.csv and.txt.

• delimiters such as comma (default as in Figure 2), semicolon, colon, tab, space, and others 
(you can choose another delimiter in the wizard later if you formatted your CSV file with 
something other than a comma, semicolon, colon, tab, or space).

• one heading per file.

Figure 2 -- CSV File
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1.2 Key Features

The Excel Import plugin can import table headings or data from an Excel or CSV file to MagicDraw as schema 
classes or instance specifications of the schema classes, map properties of an imported schema class to those 
of a target element and create a mapping diagram, and export instance specifications of a schema class or 
elements of a class mapping to an Excel or CSV file.

The following are the key features of the Excel Import plugin:

(i)   Import table headings from an Excel or CSV file as schema classes.
(ii)  Create a mapping diagram.
(iii)  Import data as instance specifications to a schema class or import data through a class map-

ping.
(iv)  Export elements or instance specifications into an Excel or a CSV file.

Full details of each feature are provided in section 2. Overview of the Excel Import.

1.2.1 Constraints

The current release of Excel Import does not support:

• importing multiple tables or linked tables from an Excel file as several schema classes.

• multiple row headings in one column in an Excel file.

• importing row headings (Figure 3).

Figure 3 -- Row Header in an Excel File

• mapping one source to multiple targets at a time.

• exporting Excel composite schema to CSV file.

• blank or empty rows (cannot be imported as elements).

• importing or exporting elements from a mapping class if either connector on the diagram or the 
diagram itself is deleted using the command Delete Symbol(s) or Delete Diagram.
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1.3 Installation

You can download and install the Excel Import plugin on your computer through the Resource/Plugin 
Manager menu in MagicDraw.

To install Excel Import using Resource/Plugin Manager:

1. Click Help > Resource/Plugin Manager on the MagicDraw main menu. The Resource/Plugin 
Manager dialog will open.

2. Click the Plugins (no cost) and select the Excel Import check box, and then click Download/
Install.

3. Once the installation is complete, a Message dialog informing you that the installation is 
complete will open. Click OK.

4. Restart MagicDraw.

You need to restart MagicDraw upon installing the Excel Import plugin on your computer to allow MagicDraw to 
load the plugin correctly.

1.4 Updates

Free updates are available through the Resource/Plugin Manager dialog in MagicDraw. 

To update the Excel Import plugin:

1. Click Help > Resource/Plugin Manager on the MagicDraw main menu. The Resource/Plugin 
Manager dialog will open.

2. Click Check for Updates > Check to see if there are any updates for the plugin.
3. Click Download/Install if you want to download it.

Note Specify HTTP Proxy Settings for the connection to access MagicDraw 
updates and resources.

Note The Excel Import plugin comes bundled with a sample of UML2.5 Meta 
Model with attributes. You can see this sample after you have down-
loaded the plugin and restarted your MagicDraw (Help > Resource/
Plugin Manager > Samples).
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2. Overview of the Excel Import
This section explains the capability of each menu represents, how to use them to import and work with your 
data, and to export data from MagicDraw to an Excel or a CSV file.

2.1 Key Features

The Excel Import plugin is capable of:

(i)   Importing table headings from an Excel or CSV file as schema classes.
(ii)  Creating a mapping diagram.
(iii)  Importing data as instance specifications to a schema class and according to a class map-

ping.
(iv)  Exporting elements or instance specifications into an Excel or a CSV file.

You can access the main features of Excel Import either from (i) the main menu in MagicDraw or (ii) the context 
menu of a schema class or a class mapping.

2.1.1 Accessing Key Features from the Main Menu

You can use the first three main features of Excel Import (see 2.1 Key Features) through the Import Data from 
Excel and Create Mapping dialog. This dialog is accessible from the main menu File > Import From > Excel/
CSV File in MagicDraw.

To open the Import Data from Excel and Create Mapping dialog:

• Click the main menu File > Import From > Excel/CSV File in MagicDraw (Figure 4). The 
Import Data from Excel and Create Mapping dialog will open (Figure 5). 
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Figure 4 -- The Excel Import Menu in MagicDraw

Figure 5 -- The Import Data from Excel and Create Mapping Dialog
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The Import Data from Excel and Create Mapping dialog contains three menus: (i) Import Table Heading 
from Excel, (ii) Create Mapping, and (iii) Import Data from Excel. They represent three of the four main 
features of Excel Import.

Each menu in the dialog (Figure 5) will open a wizard that provides step-by-step instructions to guide you to 
import your data and/or create a mapping diagram successfully.

(i) Import Table Heading from Excel helps you select an Excel or a CSV file and import the headings as 
schema classes to MagicDraw.

(ii) Create Mapping helps you select imported properties of a schema class and map them with some 
properties of a UML element, a SysML element, or a user model, and create a mapping diagram to represent 
the class mapping.

(iii) Import Data from Excel helps you either import rows of an Excel or a CSV file as instance specifications 
of a schema class or import data through a class mapping as model elements whose type is dependent on a 
target element selected in the class mapping.

The fourth feature, (iv) Exporting elements or instance specifications into an Excel or a CSV file, is 
accessible from the main menu File > Export to > Excel/CSV File in MagicDraw that opens the Export Data 
to Excel wizard. This wizard helps you export elements from a schema class or a class mapping to an Excel or 
a CSV file.

To open the Export Data to Excel wizard:

• Click the main menu File > Export To > Excel/CSV File (Figure 6) in MagicDraw. The Export 
Data to Excel wizard will open (Figure 7).

Figure 6 -- The Excel Export Menu in MagicDraw
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Figure 7 -- The Export Data to Excel Wizard

2.1.2 Accessing Key Features from the Context Menu

In addition to the main menu, a shortcut to the plugin features is available through the context menu of a 
schema class or a class mapping. You can open the context menu by clicking a schema class or a class 
mapping either in the Containment tree or on the diagram pane. The context menu provides a convenient way 
to access specific plugin commands.

The context menu of a schema class allows you to import data from a file, create mapping, and export elements 
to a file (Figure 8 and Figure 9), whereas the context menu of a class mapping allows you to import data from a 
file and export elements to a file (Figure 10).
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Figure 8 -- The Context Menu of a Schema Class in the Containment Tree

Figure 9 -- The Context Menu of a Schema Class on the Diagram Pane
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Figure 10 -- The Context Menu of a Class Mapping in the Containment Tree

2.2 Preparing Your Data Prior to Import/Export

You will need to prepare your data in an Excel or CSV file before importing them. Check your CSV file to be 
sure the heading is located in the first row, every column has a unique column name, and every row has the 
same number and name of columns.

Every row in a CSV file represents one item, and all items in the file have the same item-type document. Also 
check to see if any of the items contain a delimiter. You can separate each item in your file using a comma, a 
colon, tab, space, or a semi-colon. Most CSV files use a comma as a delimiter by default. If your file uses 
another type of delimiter, you can select the Others check box and specify the delimiter in the Import Table 
Heading from Excel wizard when you import the file as a schema class.

Figure 11 -- CSV File
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The plugin supports a table with composite headers meaning that it imports a merged column as a schema 
class and the columns under the merged column as attributes of the schema class. A table can have empty 
rows, but the plugin does not import blank rows or columns as elements. 

Figure 12 -- Composite Headers of an Excel File

Exporting elements from a MagicDraw project to an existing Excel or CSV file that contains data requires you to 
check if the header (Excel file) or the number and name of columns (CSV file) match the properties of the 
schema class that you will export. If you want to export the properties or elements to a new target file that 
contains no data, this restriction does not apply.

2.3 Importing Data as Schema Classes

Excel Import allows you to import table headings from an Excel or CSV file as schema classes in MagicDraw. 
Importing a schema class is possible by either (i) using the wizard or (ii) dragging an Excel or CSV file to a class 
diagram.

You can click the main menu File > Import From > Excel/CSV File in MagicDraw to open the Import Data 
from Excel and Create Mapping dialog, and select Import Table Heading from Excel to open the wizard. If 
you use the wizard to import table headings as schema classes, you can alternatively import rows as instance 
specifications of the schema classes at the same time. If you use the second method, which is dragging an 
Excel or CSV file to a class diagram, Excel Import will import schema classes only.

If the name of a schema class that you are going to import is the same as that of an existing one, the Excel 
Import plugin will append a numeric suffix to the imported schema class name in increments of 1 (starting at 1).

Once you import a table heading, the Excel Import plugin will create a schema class by applying the stereotype 
fileSchema with the tagged value of the fileName tag definition. 

Note • Importable Excel or CSV files must have headings in the first row, 
individual unique column names, and the same number of rows and 
name of columns.

• A blank or an empty row cannot be imported as an element.
• The plugin does not support the export of Excel composite schema 

to CSV file. 
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Figure 13 -- Schema Classes on Diagram Pane

Figure 14 -- Schema Classes on Containment Tree

2.3.1 Import Data as Schema Classes by Using Wizard

You can open the Import Data from Excel and Create Mapping dialog from the main menu by clicking File > 
Import From > Excel/CSV File. The first menu in the dialog, Import Table Heading from Excel, allows you to 
import table headings as schema classes and/or table rows as instance specifications through the wizard. You 
can select either one or both to import at the same time. Select the Import each row as an instance 
specification check box in the wizard (Figure 15) if you want to also import table rows as instance 
specifications of the schema class(es) that you are going to import.
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Figure 15 -- The Import Table Heading from Excel Wizard

The Excel Import plugin supports several delimiters such as semicolon, colon, tab, and space (Figure 16). If a 
CSV file that you want to import contains another type of delimiter, you can select Others from the Select a 
delimiter drop-down list and type the delimiter in the Others box provided in the wizard (Figure 17).

Figure 16 -- Supported Delimiters

Figure 17 -- Selecting Another Type of Delimiter

The wizard also provides you with some other options. The Specify starting header row check box allows you 
to select which row to start importing table headings. This option is useful if there are other data, for example, 

Note • When using the wizard to import table headings as schema classes, 
you can also choose the option to import rows as instance 
specifications of the schema class.
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text or paragraphs, preceding the table. If data other than table headings or rows, with the exception of those 
that come after the table, are imported, an error will occur during import. 

You may also select the Create a mapping diagram check box if you want to further map the imported 
schema class with a target element. The wizard will create a mapping diagram to represent all mapped 
elements in a class mapping.

When you import an Excel file that has one or several sheets through the wizard, the plugin allows you to select 
the to-be-imported sheet in the Select sheets step. The plugin will list only the sheets that contain data or table 
headings. If a file contains only one sheet or has several sheets but only one sheet contains data, the plugin will 
skip the Select sheets step.

2.3.2 Import Data as Schema Classes by Dragging the File

Alternatively, you can import schema classes from an Excel or CSV file by dragging it to a diagram pane in 
MagicDraw. You need to create and open a class diagram prior to importing data from the file. When you drag 
an Excel file that contains several sheets, only the sheets that contain data will be imported. The plugin imports 
composite headers as multiple schema classes. If the file is a CSV, the plugin will use comma as the default 
delimiter. 

Dragging an Excel or CSV file to a class diagram will not import data from the file as instance specifications of 
the imported schema class. You can use the Import each row as an instance specification check box in the 
Import Table Heading from Excel wizard if you want to import both table heading and its data as the schema 
classes and its instance specification respectively. For more information about importing instance specifications 
of the schema class, see section 3.1.1 Importing a Schema Class by Using the Wizard.

2.4 Mapping Schema Classes

Excel Import is also capable of creating a class mapping. A class mapping describes how a schema class maps 
to a target element. A class mapping contains mapped properties between the schema class and the target 
element. You can see connectors linking mapped properties in a mapping diagram. When you use the Create 
Mapping wizard to create a class mapping, it will ask you to select a source, which is a schema class, and a 
target element, and further select which properties of the target element that you want to map with the 
properties of the schema class. The wizard selects all properties of a schema class by default.

The source element is a schema class while the target element can be a UML profile, a SysML profile, or a user 
model.

The result of imported elements varies according to the target element you have selected:

• If it is a meta model, the result will be the type of the meta class or the applied stereotype.

• If it is a user model, the result will be the instance specifications of a user model as shown in 
Figure 18. 

The wizard allows you to choose all possible target elements for mapping in a treeview including UML2.5, 
SysML Profile, and a user model. 

Note • Dragging an Excel or a CSV file to a class diagram will import table 
headings as schema classes. You cannot use this method to import 
rows as instance specifications.
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Figure 18 -- Target Elements for Mapping

A successful mapping of a schema class and a target element (a UML profile, a SysML profile, or a user model) 
will result in a new Composite Structure diagram, which is called mapping diagram, created in the selected 
package in the Containment tree. A mapping diagram shows you all of the properties of a source schema class 
and a target element that you have selected for mapping. If a property’s name in the source schema class is 
identical to the one in the target element, the plugin will map them automatically with connectors. Otherwise, 
use the connectors to connect the properties of the schema class and the target element to map them. You can 
remove the connectors or connect other mapped properties in the diagram mapping.

Note To map a property as a name of a target element, drag a connector 
from the property to the target element’s box (Figure 19). 
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Figure 19 -- Map a Property as an Element Name

2.5 Importing Data to a Schema Class or Importing Data through a 
Class Mapping

There are three methods to import data from table rows in an Excel or CSV file:

(i)   Import them as instance specifications of a schema class when importing the schema class.
(ii)  Import them as instance specifications of a schema class after importing the schema class.
(iii)  Import them through a class mapping.

You can import instance specifications at the same time you import a schema class by using the Import Table 
Heading from Excel wizard. The wizard provides the Import each row as an instance specification check 
box (Figure 16), if you want to opt for this option. The first method helps you import table headings as schema 
classes and table rows as instance specifications of the schema classes simultaneously. The second method is 
a means of importing table rows as instance specifications to an already created schema class.

The third method, importing data through a class mapping, means importing data from table rows from an Excel 
or CSV file according to the mapped target element type in the class mapping.

The Import Data from Excel menu in the Import Data from Excel and Create Mapping dialog opens the 
Import Data from Excel wizard. This wizard helps you select a file from which you want to import instance 
specifications to a schema class or import data through a class mapping that you have created. 

If the name and the type of an imported element is the same as the name and the type of an existing element 
(include the inherited element type), the Excel Import plugin will use the imported one to overwrite and update 
the existing one only if they are in the same package or sub-package. 

When you import data through a class mapping, the result of import will be in accordance with the target 
element type of the class mapping. When mapping properties of a schema class and a target element, you can 
choose one out of three possible target elements: a UML profile, a SysML profile, or a user model. Therefore, if 
your class mapping has a user model as the target, the imported data will become instance specifications of the 
user model. However, if your class mapping has a UML or a SysML profile as the target, the imported data or 
elements will become a UML or a SysML element of the selected type.
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2.6 Exporting Elements to Excel or CSV File

Excel Import provides the Export Data to Excel wizard to help you export either instance specifications of a 
schema class or imported elements of a class mapping to an Excel or CSV file in no time. You can use the 
main menu or the context menu to open the Export Data to Excel wizard in MagicDraw:

(i)   On the main menu, click File > Export To > Excel/CSV File.
(ii)  Right-click a schema class in the Containment tree or on the diagram pane, and select Tools 

> Export Data to Excel.
(iii)  Right-click a class mapping in the Containment tree > Tools > Export Data to Excel.

You can either select any existing file to store the exported elements or create a new file.

If the wizard cannot import data from a file as a schema class or instance specifications, or map the schema 
class with a selected element successfully, or fails to export elements to a file, you will see an error message 
with the cause of the error in the Notification Window in MagicDraw (Figure 20).

Figure 20 -- The Notification Window in MagicDraw
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3. Using Excel Import
The Excel Import plugin of MagicDraw makes it easier to import and export your data. This plugin can 
automatically create a schema class for every header and an instance specification for every row of data 
imported from an Excel or CSV file. Once you have imported a schema class, you can map its properties with 
those of the target element or model in MagicDraw, view the mapped properties of a class mapping on a 
mapping diagram, and continue mapping the properties using the connectors.

The plugin also helps you export any instance specifications or mapped properties of the element in your 
project into.xls, xlsx, csv, or txt file format.

Step-by-step instructions to work with the Excel Import plugin in MagicDraw are after the description of the 
feature in the Import Data from Excel and Create Mapping dialog and other options provided in the wizard. 
You can open the dialog in MagicDraw by clicking the main menu File > Import From > Excel/CSV File.

The Import Data from Excel and Create Mapping dialog contains three menus:

• Import Table Heading from Excel

• Create Mapping

• Import Data from Excel

This section explains what each menu can do and provides step-by-step instructions to help you import data as 
schema classes and its instance specifications, create a mapping diagram, and import data according to your 
mapping. As for the plugin’s capability to export data to Excel or CSV format files, you can access it on the main 
menu in Magic Draw by clicking File > Export To > Excel/CSV File. At the end of this section, you can find 
some examples of how to export your data into an Excel or CSV file.

3.1 Import Table Heading from Excel

There are two methods to import a table headings from an Excel or CSV file as a schema class. Both ways 
accomplish the same thing, but have subtle and important differences.

3.1.1 Importing a Schema Class by Using the Wizard

3.1.2 Importing a Schema Class by Dragging the File to a Class Diagram

Once the plugin has imported the schema class, you can see the imported class in the Containment tree and 
on the diagram pane. You can undo your last import by clicking Edit on the main menu, and then Undo.

The Import Table Heading from Excel menu in the Import Data from Excel and Create Mapping dialog 
opens the wizard that helps you import table headings as schema classes and table rows as instance 
specifications of the schema class. The Import Table Heading from Excel wizard contains options that allow 
you to:

• Select which file to import schema classes from (Excel or CSV file).

• Select a delimiter (CSV file).

• Select a specific row to start importing schema classes.

• Import table rows as instance specifications.

• Map an imported schema class with a target element through the Create Mapping wizard.

• Create a class diagram that shows all imported schema classes.

This section shows you how to import schema classes from an Excel or CSV file only. For more information 
about importing instance specifications, see section 3.3 Importing Data to a Schema Class or Importing 
Data Through a Class Mapping 3.2 Mapping a Schema Class to an ElementFor more information about 
mapping a schema class, see section 3.2 Mapping a Schema Class to an Element.
21                                                                                                                                                                                                                       Copyright © 2011-2014 No Magic, Inc.



EXCEL IMPORT
Using Excel Import
The following sections show you how to use the wizard and drag-and-drop operation to import a table heading 
as a schema class.

3.1.1 Importing a Schema Class by Using the Wizard

This method helps you import table headings from a text or a spreadsheet file as schema classes.

To import data from an Excel or CSV file to a MagicDraw project as a schema class by using the wizard:

1. Click File on the MagicDraw main menu and click Import From > Excel/CSV File. The Import 
Data from Excel and Create Mapping dialog will open and the Import Table Heading from 
Excel menu will be selected by default (Figure 21).

Figure 21 -- The Import Data from Excel and Create Mapping Dialog

2. Click OK. The Import Table Heading from Excel wizard will open (Figure 22). 
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Figure 22 -- The Select a File Option Page

3. Click Browse to find an Excel or CSV file that you want to import. The Select a file dialog will 
open (Figure 23).

Figure 23 -- Selecting an Excel or CSV File 
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4. Select the file and click Open. The path filename of the selected file will appear in the Select a 
file box (Figure 24). If you select a CSV file, the Select a delimiter drop-down list will be 
enabled for you to choose a delimiter used in your file (Figure 25).

Figure 24 -- The Selected Path Filename

Figure 25 -- Selecting a Delimiter for CSV File

5. Once you have selected the file to import as a schema class, you can (Figure 26):
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(i) Select the Specify starting header row check box if you want Excel Import to start import 
headings at a specific row.

(ii) Select the Import each row as an instance specification check box if you want to import 
data from the file as instance specifications of the schema class. For more information about 
importing instance specifications, see section 3.3 Importing Data to a Schema Class or 
Importing Data Through a Class Mapping.3.2 Mapping a Schema Class to an Element

(iii) Select the Create a mapping diagram check box if you want to map the to-be-imported 
schema class to an element in your project. For more information about diagram mapping, see 
section 3.2 Mapping a Schema Class to an Element.

Figure 26 -- Additional Options for Import

6. You may click either (i) Finish and skip steps 7 to 14 or (ii) Next and the Select sheets option 
page will open (Figure 27). 

Note If you click Finish at this point, the wizard will:
• Import table headings in all sheets that contain data as schema 

classes.
• Save the schema classes under the Data module.
• Create a class diagram to represent the schema classes and save it 

under the Data module.
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Figure 27 -- Selecting Sheets in an Excel File

7. You can select more than one sheet (if the file has multiple sheets contain data). All of the 
sheets in the file to be imported are selected by default.

8. You may click either (i) Finish and skip steps 9 to 14, or (ii) Next and the Select a package 
option page will open (Figure 28).

Note The wizard will skip the Select sheets option page if:
• A selected Excel file has only one sheet.
• A selected Excel file has several sheets but only one sheet contains 

data.
• A CSV file is selected.

Note If you click Finish at this point, the wizard will:
• Import table headings in the selected sheets as schema classes.
• Save the schema classes under the Data module.
• Create a class diagram to represent the schema classes and save it 

under the Data module.
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Figure 28 -- Selecting a Package as the Owner of the Schema Class

9. Select a package as the owner of the to-be-imported schema class and/or its instance 
specifications. You can (Figure 27):
(i)   Select an existing package by selecting it from the treeview,
(ii)  Create a new one by clicking the Create button, or
(iii)  Clone an existing one by clicking the Clone button.

Figure 29 -- The Select a Package Option Page
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10. Click either (i) Finish and skip steps 11-12, or (ii) Next to create a mapping diagram. The 
Create a diagram option page will open (Figure 30).

Figure 30 -- The Create a Diagram Option Page

11. In this step, you need to do several things:
11.1 Either (i) select the Create a new diagram check box to create a new diagram 

(the check box is selected by default) or (ii) deselect the check box if you do not 
want to create a new diagram. 

11.2 You can name your diagram in the Type diagram name box.
11.3 (i) Select the diagram’s owner from the treeview, (ii) create a new one, or (iii) 

clone it.
12. Click Finish. The Excel Import plugin will import data from the selected file as a schema class 

and/or its instance specifications and display them under the selected or created package in the 
Containment tree in MagicDraw. If you create a new diagram, it will open and display the 
schema class on the diagram pane (Figure 31).

Note If you click Finish at this point, the wizard will:
• Save the schema classes under the selected package.
• Create a class diagram to represent the schema class under the 

Data module.
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Figure 31 -- Import of Data as a Schema Class and/or Its Instance Specifications is Completed

3.1.2 Importing a Schema Class by Dragging the File to a Class Diagram

Just like using the wizard, this method also allows you to import data from an Excel or CSV file as a schema 
class in your MagicDraw project by dragging them. This is relatively faster because you simply drag the file 
stored on your computer to a class diagram in MagicDraw. Before importing data from a file as a schema class 
using this method, you need to have the class diagram open in the diagram pane.

Once you have dragged an Excel or CSV file to a class diagram in MagicDraw, Excel Import will import all table 
headings in the file as schema classes and store them in the package where you have created the class 
diagram. Upon each successful import, you can see all imported classes shown in the class diagram on the 
diagram pane.

To import data from an Excel or CSV file as a schema class by dragging the file:

1. Create or open a class diagram in a MagicDraw.
2. Drag the file to the class diagram on the diagram pane in MagicDraw (Figure 32). You will see 

the imported classes in the class diagram on the diagram pane (Figure 33).
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Figure 32 -- Dragging an Excel File to a Class Diagram

Figure 33 -- Importing Data as a Schema Class Completed

Note • Dragging an Excel or a CSV file to a class diagram will only import 
table headings as schema classes.

• The default delimiter in a CSV file is a comma.
• The Excel Import plugin imports every sheet of an Excel file which 

contains data, and ignores blank sheets.
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3.2 Mapping a Schema Class to an Element

You can also use the Excel Import plugin to select the imported properties of the schema class and some 
properties of a UML element, a SysML element, or your own model, and map them on a mapping diagram. 
Excel Import can create a mapping diagram to represent the class mapping.

You can create a mapping diagram in either way:

3.2.1 Creating a Mapping Diagram when Importing a Schema Class

3.2.2 Creating a Mapping Diagram after Importing Schema Classes

You can map a schema class with a UML meta model by selecting the UML profile (UML2.5 or UML2.5 Meta 
Model with attributes.mdzip) as the target element. Once you have a class mapping, you can import data 
according to the mapping. For more information about importing data to a class mapping, see 3.3 Importing 
Data to a Schema Class or Importing Data Through a Class Mapping

3.2.1 Creating a Mapping Diagram when Importing a Schema Class

In addition to the schema class and/or instance specifications import, the wizard allows you to simultaneously 
create a mapping diagram that represents a class mapping that contains mapped properties of a schema class 
and an element. When you create a mapping diagram using the Excel Import plugin, it allows you to map 
properties of an imported schema class to any selected element of UML, SysML, or a user model.

To create a mapping diagram when importing a schema class:

1. Click File > Import From > Excel/CSV File. The Import Data from Excel and Create 
Mapping dialog will open (Figure 34).

Figure 34 -- The Import Table Heading from Excel Menu

2. The Import Table Heading from Excel menu is selected by default (Figure 34). Click OK. The 
Import Table Heading from Excel wizard will open (Figure 34). 
31                                                                                                                                                                                                                       Copyright © 2011-2014 No Magic, Inc.



EXCEL IMPORT
Using Excel Import
Figure 35 -- Selecting a Source Schema Class for Mapping

3. Click Browse to find a file whose data you want to import as a schema class.

Figure 36 -- The Create a Mapping Diagram Check Box for Class Mapping

4. Select the Create a mapping diagram check box (Figure 34).
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5. Click either (i) Next or (ii) Finish. If you click Finish, skip steps 6-11.
6. If you select an Excel file that has data in several sheets, you can select which sheet to import 

(Figure 35). If your file is a CSV file, the Select sheets option will be skipped.

Figure 37 -- The Select Sheets Option for Class Mapping

7. Click either (i) Next or (ii) Finish. If you click Finish, skip steps 8-11.

Figure 38 -- The Select a Package Option for Class Mapping

8. Select a package from the treeview (Figure 38), create, or clone it to store the class mapping.
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9. Click either (i) Next if you want to create a class diagram to show all imported data or (ii) 
Finish. If you click Finish, skip steps 10-11.

Figure 39 -- The Create a Diagram Option Page

10. You can rename the diagram and select a package (owner) to store the class diagram from 
the treeview (Figure 39). If you clear the Create a new diagram check box, the diagram’s name 
and owner fields will be disabled.

11. Click Finish. The Create Mapping wizard will open and select the imported schema class as 
the mapping source automatically (Figure 40).
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Figure 40 -- The Create Mapping Dialog

12. Select a target element that you want to map with the selected schema class from UML 2.5 
Profile, SysML Profile, or your own model (Figure 40).
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Figure 41 -- Select a Target Element of UML 2.5 for Mapping

13. Once you have selected a target element, click either (i) Next or (ii) Finish (Figure 41). If you 
click Finish, skip steps 14-17.

Note If you click Finish at this point, the wizard will:
• Use all properties of the selected schema class and the selected 

properties of the target element to create a class mapping.
• Name the mapping class and mapping diagram according to the 

following format <schemaName> mapping.
• Save the class mapping and mapping diagram at a location where 

the schema class is stored.
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Figure 42 -- Selecting Properties of the Schema Class and Target Element

14. Select one or more properties of the schema class and the target element to map (Figure 42).
15. Click either (i) Next or (ii) Finish. If you click Finish, skip steps 16-17.

Note If you click Finish at this point, the wizard will:
• Use the selected properties of the target element to create a class 

mapping.
• Name the mapping class and mapping diagram according to the 

following format <schemaName> mapping.
• Save the class mapping and mapping diagram at a location where 

the schema class is stored.
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Figure 43 -- Selecting a Package to Store the Class Mapping

16. You can rename and select or create a package to store the class mapping (Figure 43).
17. Click Finish.

3.2.2 Creating a Mapping Diagram after Importing Schema Classes

The Create Mapping menu in the Import Data from Excel and Create Mapping dialog is useful if after you 
have imported a schema class, you want to further map its properties to those of a target element in 
MagicDraw. Upon selecting which properties to map through the wizard, a mapping diagram will be created. A 
mapping diagram allows you to map the selected properties of the schema class and the target element using 
connectors.

The Excel Import plugin automatically maps properties whose attribute names are identical. You can see these 
attribute names mapped automatically using connectors in a mapping diagram. You may delete these 
mappings from the diagram if desired. Excel Import select all properties of a schema class for mapping by 
default.

To map a schema class imported from an Excel or CSV file to a target element in MagicDraw through the main 
menu:

1. Click File > Import From > Excel/CSV File. The Import Data from Excel and Create 
Mapping dialog will open.

2. Click the Create Mapping menu and click OK (Figure 44). 
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Figure 44 -- The Create Mapping Menu

3. The Create Mapping wizard will open the first option page (Figure 45).

Figure 45 -- The Select a Class Option Page

4. Select a schema class that you want to map to an element from the treeview and click Next. 
The Select a target element option page will open (Figure 46).
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Figure 46 -- The Select a Target Element Option Page

5. Select a target element from the Target element tree (Figure 46) that you want to map with the 
selected schema class. The available target elements are UML 2.5 (UML2.5 Meta Model with 
attributes.mdzip) profile for UML element, SysML profile for SysML element, or your own 
model.

6. Once you have selected the target element, click either (i) Next or (ii) Finish. If you click 
Finish, skip steps 7-10.

Note If you click Finish at this point, the wizard will:
• Use all properties of the selected schema class and the selected 

properties of the target element to create a class mapping.
• Name the mapping class and mapping diagram according to the 

following format <schemaName> mapping.
• Save the class mapping and mapping diagram at a location where 

the schema class is stored.
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Figure 47 -- The Select Properties Option Page

7. Select the properties (Figure 47) of the selected target element to map with the selected 
schema class. You may select multiple properties.

8. Click either (i) Next or (ii) Finish. If you click Finish, skip steps 9-10.

Note If you click Finish at this point, the wizard will:
• Use all properties of the target element you have selected to create a 

class mapping.
• Name the mapping class and mapping diagram according to the 

following format <schemaName> mapping.
• Save the class mapping and mapping diagram at a location where 

the schema class is stored.
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Figure 48 -- The Create a Mapping Option Page

9. Name the to-be-created class mapping in the Mapping name text box and select a package 
that will contain the class mapping and diagram from the treeview (Figure 49).

10. Click Finish. The new mapping diagram will appear in the Containment tree and on the 
diagram showing the mapped properties of the schema class and the element.

3.2.3 Creating a Mapping Diagram Through the Context Menu

You can also map a schema class to an element by using the context menu of the schema class either in the 
Containment tree (Figure 49) or on the diagram pane (Figure 50) in MagicDraw, and create a mapping 
diagram.

To create a mapping diagram through the context menu:

1. Right-click a schema class either (i) in the Containment tree (Figure 49) or (ii) on the diagram 
pane (Figure 50).
42                                                                                                                                                                                                                       Copyright © 2011-2014 No Magic, Inc.



EXCEL IMPORT
Using Excel Import
Figure 49 -- The Create Mapping Context Menu in the Containment Tree
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Figure 50 -- The Create Mapping Context Menu on the Diagram Pane

2. Select Tools > Create Mapping. The Create Mapping wizard will open and skip the Select a 
class step (Figure 51).
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Figure 51 -- Selecting a Target Element for Class Mapping

3. Select a target element that you want to map with the selected schema class. The available 
target elements are UML2.5 (UML2.5 meta model with attribute.mdzip) profile for UML 
element, SysML profile for SysML element, or your own model.

4. Click either (i) Next or Finish. If you click Finish, skip steps 5-8.
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Figure 52 -- Selecting Properties of the Target Element

5. Select the properties of the target elements that you want to map to the schema class.
6. Click either (i) Next to open the Create a mapping option page (Figure 53) or (ii) Finish to skip 

steps 7-8.
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Figure 53 -- Creating Class Mapping

7. You can name the to-be-created class mapping in the Mapping name box and select a 
package to store the class mapping (Figure 53).

8. Click Finish. The class mapping will appear in the Containment tree and open on the diagram 
pane.

3.3 Importing Data to a Schema Class or Importing Data Through a 
Class Mapping

The Excel Import plugin provides several ways to import data from an Excel or a CSV file as model elements in 
MagicDraw. This section describes how to import data to a schema class and import data through a class 
mapping. You can import data:

• As instance specifications of a schema class when you are importing the schema class.

• As instance specifications of a schema class after you have imported the schema class.

• Through a class mapping.

3.3.1 Importing Instance Specifications when Importing Schema Classes

When you are importing table headings from an Excel or CSV file as a schema class, you can also import the 
rows in the file as instance specifications of the schema class at the same time.You can use the Import Table 
Heading from Excel menu in the Import Data from Excel and Create Mapping dialog. 
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To import instance specifications when importing a schema class:

1. Click File on the MagicDraw main menu and click Import From > Excel/CSV File. The Import 
Data from Excel and Create Mapping dialog will open and the Import Table Heading from 
Excel menu will be selected by default (Figure 54).

Figure 54 -- Importing Instance Specifications through the Import a Schema Class Option in the Wizard

2. Click OK. The Import Table Heading from Excel wizard will open (Figure 55). 
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Figure 55 -- Importing Instance Specifications Using the Import Table Heading from Excel Wizard

3. Click Browse to find an Excel or CSV file whose data you want to import both as schema class 
and instance specifications of the schema class.

4. Select a delimiter (if you select a CSV file) from the Select a delimiter drop-down list or 
Comma will be selected as the delimiter by default. Skip this step if you select an Excel file.

5. Select the Import each row as an instance specification check box.
6. Click either (i) Finish to start the import or (ii) Next if you want to select a package as the owner 

of the imported class and its instance specifications. Otherwise, Data will be selected as the 
default package. Excel Import will import data from the file both as schema class and its 
instance specifications (Figure 56).
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Figure 56 -- Importing Schema Class and Instance Specifications from CSV

3.3.2 Importing Instance Specifications after Creating a Schema Class

The other way to import data as instance specifications is after you have imported or created a schema class. 
You can import instance specifications to a created schema class in two ways:

(i) Through the main menu by clicking File > Import From > Excel/CSV File and select Import Data 
from Excel.

(ii) Through the context menu by right-clicking a schema class in the Containment tree or on the class 
diagram and select Tools > Import Data from Excel.

Either method will open the Import Data from Excel wizard. The former allows you to select a schema class 
and the latter automatically selects it. 

(i) To import data as instance specifications of a schema class through the main menu:

1. Click File on the MagicDraw main menu and click Import From > Excel/CSV File. The Import 
Data from Excel and Create Mapping dialog will open (Figure 57). 
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Figure 57 -- Importing Instance Specifications of Schema Class by Using the Wizard

2. Click Import Data from Excel > OK. The Import Data from Excel wizard will open 
(Figure 58).

Figure 58 -- Selecting a File to Import Option Page

3. Click Browse to find the file from which to import the instance specifications. If you select a 
CSV file, the Select a delimiter drop-down list will be enabled.

4. Click Next. If you select an Excel file with multiple sheets that contain data, you can select the 
sheets to import from the file (Figure 59). 
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Figure 59 -- Selecting a Sheet(s) to Import

5. Select one or more sheet to import from the file and click Next (Figure 59).

Figure 60 -- Selecting a Schema Class for the Instance Specifications

6. Select a schema class to import the instance specifications and click either (i) Finish to import 
the instance specifications into the package where the schema class is stored, or (ii) Next to 
select a package to import the instance specifications (Figure 61).
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Figure 61 -- The Select a Package Option Page

7. Select a package that will contain the instance specifications to import from the treeview 
(Figure 61). 

8. Click Finish. 

(ii) To import data as instance specification of a schema class through the context menu:

1. Right-click a schema class either (i) in the Containment tree or (ii) on the class diagram and 
select Tools > Import Data from Excel (Figure 62). The Import Data from Excel wizard will 
open (Figure 63) and the schema class will be selected by default in the Select a mapping 
option page.

Note If the file of the selected schema class has been opened before, the 
plugin will automatically select it by default in the Select a file option 
page. 
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Figure 62 -- Importing Instance Specifications through the Context Menu

Figure 63 -- Importing Instance Specifications of the Selected Schema Class

2. Click Browse to find a file to import as instance specifications of the selected schema.
3. Click either (i) Finish to start the import or (ii) Next to select a specific sheet from the file to 

import the instance specifications. And continue with the rest of the steps.

3.3.3 Importing Data through a Class Mapping

You can also import model elements through a class mapping. A class mapping contains properties of a 
schema class and a target element that you have mapped together. The type of the target element that you 
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selected in the class mapping determines how the plugin imports and creates the model elements. If the target 
element is a user model, the plugin will import data as instance specifications of the user model. However, if the 
target type is a UML or a SysML, the plugin will import data as UML or SysML element type respectively.

Importing data through a class mapping requires the number and the name of columns in the file to be the 
same as those in the selected class mapping.

The Import Data from Excel menu in the Import Data from Excel and Create Mapping dialog (Figure 64) 
opens the wizard that allows you to import data according to the class mapping you created. This menu is also 
useful if you want to import data from an Excel or CSV file as instance specifications of the schema class you 
have imported. See section 3.3.2 Importing Instance Specifications after Creating a Schema Class for 
details on importing instance specifications using the Import Data from Excel menu.

You can open the wizard to import elements from a class mapping through either (i) The main menu or (ii) The 
context menu. If you want to import elements by using the main menu, you need to click File > Import From > 
Excel/CSV File > Import Data from Excel. If you use the context menu, you can right-click a class mapping in 
the Containment tree in MagicDraw and select Tools > Import Data from Excel. 

Either method opens the Import Data from Excel wizard. The only difference is that the context menu will 
choose the class mapping, which you have already selected in the Containment tree, in the Select a mapping 
option page by default. However, you can change the default class mapping in the wizard to another one.

(i) To import data according to a class mapping through the main menu:

1. Click File on the MagicDraw main menu and click Import From > Excel/CSV File. The Import 
Data from Excel and Create Mapping dialog will open (Figure 64).

Figure 64 -- The Import Data from Excel Menu

2. Click the Import Data from Excel menu and click OK. The Import Data from Excel wizard will 
open (Figure 65).
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Figure 65 -- The Select a File Option Page

3. Click Browse to find an Excel or CSV file.
4. Select a file and click Open.
5. Click Next. If the file you have selected in step 3 above is an Excel file that has data in more 

than one sheet contain data, the Select sheets option will be enabled (Figure 66). Otherwise, 
skip step 6.

Figure 66 -- Selecting Excel Sheets to Import

6. Select one or more sheets in the Excel file whose data you are going to import and click Next. 
The Select a mapping option will open (Figure 67).
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Figure 67 -- Selecting a Class Mapping Option Page

7. Select a class mapping to which you want to import the elements.
8. Click either (i) Finish to import the elements into the package where the class mapping is 

located or (ii) Next to select a new package using the Select a package option (Figure 68).

Figure 68 -- Selecting a Package

9. Select, create, or clone a package to store the to-be-imported elements from the treeview.
10. Click Finish.
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To import data according to a class mapping through the context menu:

1. Right-click a class mapping in the Containment tree (Figure 69).

Figure 69 -- Opening the Context Menu of a Class Mapping in the Containment Tree

2. Select Tools > Import Data from Excel. The Select a file page will open (Figure 70).
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Figure 70 -- Importing Data through the Context Menu

3. You can click:

(i) Browse to find a file and click Finish.

(ii) Finish and skip the following steps.

(iii) Next to select the sheets of using the Select sheets option (Figure 71). If you are importing 
a CSV file, the wizard will skip the Select sheets page and open the Select a mapping 
page (Figure 72).

Note If you click Finish at this point, the wizard will:
• Import data from the file and the sheet of the schema class of the 

selected class mapping.
• Save imported data in the package where the class mapping is 

located.

Note The Select sheets option page will not open if:
• a selected Excel file has only one sheet.
• a selected Excel file has several sheets but only one sheet contains 

data.
• a CSV file is selected.
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Figure 71 -- Selecting Sheets to Import Option Page

4. Select one or more sheets in the Excel file with the data to import and click Next. The class 
mapping you have selected in the Containment tree will open in the Select a mapping option 
page (Figure 72).

Figure 72 -- Selecting a Class Mapping Option Page

5. You can select another class mapping from the treeview.
6. Click either (i) Finish to import the element into the package where the class mapping is 

located, or (ii) Next to select a package to store imported elements through the Select a 
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package option page (Figure 73).

Figure 73 -- Selecting a Package to Store the Imported Elements

7. Select, create, or clone a package to store the to-be-imported elements or instance 
specifications from the treeview (Figure 73).

8. Click Finish.

3.4 Exporting Instance Specifications or Elements

You can export instance specifications of a schema class and/or elements of a class mapping from MagicDraw 
to an Excel or CSV format file. You can open the Export Data to Excel dialog from any of the following:

(i)   The MagicDraw main menu File > Export To > Excel/CSV File.
(ii)  The context menu of a schema class in the Containment tree and on the diagram pane.
(iii)  The context menu of a class mapping in the Containment tree.

If you open the Export Data to Excel dialog through the context menu of a schema class or a class mapping, 
you do not have to select the schema class or the class mapping as it will be selected by default.

When you export elements from a schema class or a class mapping to an existing Excel or CSV file, the file 
needs to have columns that match the number and name of a schema class to be exported. The target file can 
be a new or an existing file. Excel Import does not support the export of Excel composite schema to CSV file.

To export instance specifications and/or elements from MagicDraw to an Excel or CSV file:

1. Do any of the following:

(i) Click File > Export To > Excel/CSV File on the main menu (Figure 74). The Export Data to 
Excel dialog will open (Figure 77).
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(ii) Right-click a schema class or a class mapping in the Containment tree > Tools > Export 
Data to Excel (Figure 75). The Select a file option page will open (Figure 79) and skip steps 
2-3.

(iii) Right-click a schema class on the diagram pane > Tools > Export Data to Excel 
(Figure 76). The Select a file option page will open (Figure 79) and skip steps 2-3.

Figure 74 -- Export Data to Excel/CSV File Menu

Note Opening the Export Data to Excel wizard through a schema class or a 
mapping class’ context menu will select the schema class or the map-
ping class by default; therefore, the wizard will skip the Select a map-
ping option page.
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Figure 75 -- Export Data to Excel Context Menu in the Containment Tree

Figure 76 -- Export Data to Excel Context Menu of a Schema Class on the Diagram Pane

2. You can export either (i) elements of a class mapping by selecting a class mapping from the 
treeview (Figure 77) or (ii) instance specifications of a schema class by selecting a schema 
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class from the treeview (Figure 78).

Figure 77 -- Exporting Elements of a Class Mapping

Figure 78 -- Exporting Instance Specifications of a Schema Class

3. Click Next. The Select a file option page will open (Figure 79).
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Figure 79 -- Selecting a File to which Elements will be Exported

4. Click Browse to find a file, or create a new one to store the exported elements by type a file 
name, select a file extension, and click Save. 

5. Click either (i) Finish to export all elements associated to the selected schema class or class 
mapping or (ii) Next. If you click Next, the Export data to file option page will open (Figure 80).

Note If you click Finish at this point, the wizard will:
• Export all the element associated to the selected schema class or 

class mapping.
• If you select a new Excel file to export, the Sheet1 is created to store 

the exported element by default.
• If you select a new CSV file to export, the comma is used as 

delimiter by default. 
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Figure 80 -- Exporting Elements to a Specific File

6. To export to an Excel file, either (i) select a sheet to export the elements of the selected 
schema class or a mapping class from the Select a sheet drop-down list or (ii) type a new 
sheet name.

7. Select an element scope that you want to export from the treeview. If you do not select any 
element scope, Excel Import will export all elements belong to the selected schema class or 
mapping class by default.

8. Click Finish. The elements and/or instance specifications will be exported to the selected sheet 
or file.

Note • If you select an Excel or CSV file that has existing data, its columns 
must match the properties of the schema class. Otherwise, an error 
will occur during export and an error message will open in the 
Notification Window in MagicDraw.

• If you select a new Excel file to export your data, the default target is 
the first sheet (Sheet1).

• If you select a new CSV file to export your data, the default delimiter 
is comma.

• The default element scope is to export all elements owned by a 
selected schema class.
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Appendix

The Excel Import Plugin Profile

The Excel Import has two stereotypes that will be used to apply to a schema class and a class mapping. The 
two stereotypes are as follows:

(i)   fileSchema
(ii)  classMapping

The stereotypes are located in the Excel Import Profile (Figure 82). You can see these stereotypes in the 
Containment tree in MagicDraw by clicking the Show Auxiliary Resources icon and expand Excel Import 
Profile (Figure 81).

Figure 81 -- Displaying Excel Import Stereotypes

Figure 82 -- Excel Import Stereotypes
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Table 1 describes the details of the stereotypes of Excel Import.

Table 1 -- The Stereotypes of Excel Imports

Terminology

Schema class

The term schema class in this user guide refers to a table heading from an Excel or CSV file that has been 
imported using the Excel Import plugin. The fileSchema stereotype is applied to this schema class.

Class mapping

A class mapping contains mapped properties of a schema class and a target element. The classMapping 
stereotype is applied to this class mapping.

Mapping diagram

A mapping diagram is a Composite Structure diagram that illustrates a mapping of properties of a schema class 
to the properties of a target element and it uses connectors to indicate mapping relationships.

Composite headers

The table with composite headers means a table with two or more merged columns under one headers. A 
merged column will be imported as a schema class and the columns under it will be imported as attributes of 
the schema class.

Icon Stereotype Name Function Extension Tag Definition

fileSchema Records a filename of an 
Excel or CSV file whose 
data have been imported 
as schema classes.

Class fileName: String: records 
a filename of an imported 
schema class from an 
Excel or CSV file.

classMapping Specifies a class mapping 
associated with a schema 
class and a target class.

Class -
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