Cameo Requirements Modeler Plugin 18.3 Beta Documentation

Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Current »

You can export ReqIF files to be used with:

  • IBM DOORS 9.4, 9.5, and 9.6
  • IBM DOORS Next Generation
  • PTC Integrity
  • Polarion REQUIREMENTS
  • Siemens Teamcenter
  • Dassault Systemes Reqtify

Exporting requirements to ReqIF files ensures that all html formatting, images and hyperlinks are represented in ReqIF format file properly. You can choose to export project elements or specifications, also, advanced users can create automated exports and scheduled exports from Teamwork Server projects.

It is recommended to export requirements into a separate project which can later be used in other models as a used project.

 

To export requirements to a ReqIF file


  1. Open a project from which you want to export requirements.
  2. From the File menu, select Export To > Requirement Interchange Format (ReqIF) File.
  3. Choose to export one of the following:
    • Elements
    • Specifications
  4. In the opened Select Elements / Select Specification Package dialog, select the elements or specification packages you want to export and click . They then appear in the Selected elements list on the right.

  5. When you're done selecting, click OK.

  6. In the Select ReqIF file dialog, select the output location for the exported ReqIF file, then select the file you want to export or type the file name to create a new one.

  7. In the ReqIF Flavor pane on the right of the Select ReqIF file dialog, select the flavor of your exported ReqIF file.

  8. Click Export.

When the ReqIF file is exported, a notification message appears, stating the quantity of exported specifications, elements and relationships. If you choose to export elements only, the message doesn't contain lines that indicate exported specifications and relationships.
 
Click the Note: you can change import/export and mapping options here link in the notification message, if you want to change these options.

Notification message informing about exported requirements

 

The notification message is displayed for a fixed duration, but you can find all project notification messages in the Notification Window. To open the Notification Window, click Window > Notification Window, or press Ctrl + M.

Changing requirements exporting options

Changing requirements exporting options is mostly expedient if you have a custom requirement type defined, or you are exporting not a requirement file but another type of data, for example, test cases.

A requirement type is limited to class and class extended types.

You can change the following export options:

  • Specify an element type to create for the objects you are exporting
  • Specify a relationship type to create for the relationships you are exporting
  • Specify a path to the output location for exported resources (images, documents, etc.)
  • Choose whether to export all properties or not and form a list of ignored and not exported properties


To change ReqIF file exporting options


  1. Click Options > Project. The Project Options dialog opens.
  2. In the options group list, select General, then scroll down to the ReqIF options group.
  3. Click a desired option specification cell to change it's value. 
  4. Click OK after you are finished.

 

  • No labels