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More information about working with reports in Report Wizard
Sample model

Report Wizard provides predefined report data templates that you can use to generate a report. The built-in report data template consists of several
report data variables such as title, author, scope, and purpose that you can modify and adjust to meet your needs. You can also create a new report
data template as needed, and manage the variables using the report data management pane.

This section defines report data, and how to use it in your report to represent variables that you want to include. Click the following links to navigate to
the content of this page.
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Report Data and Variables
A report in Report Wizard has a collection of variables which are called report data. Report Wizard provides a built-in report data for every predefined

template. The built-in report data comes with predefined variables and values which you can edit or delete. You can also add more variables to the
built-in report data.



Manage report variables
Create, modify, delete variables or set values for them.
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The built-in report data's predefined variables and values in Report Wizard.
You can create your own report data, and add variables and child variables under it if you do not want to use the built-in one. Report Wizard also

allows you to create a report data as an element in the Containment tree inside a MagicDraw project by using the Report Profile which allows you to
commit the Report Data to Teamwork Server, and share it with other users.

Report Data Management Pane

Report Wizard stores the built-in report data in the Report Data management pane which helps you to organize information into groups, and keep
revision history created in a MagicDraw project.

This pane also allows you to:

® Create, edit, delete, or clone a Report Data.
® Create or organize the variables in a Report Data.



Select a report data

Select a report data (a collection of repart variables, e.q., Author, Publisher, etc.)
which you would like to be induded in the generated report. A built-in report data is
provided for every predefined template.
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Selecting the built-in report data in the Report Data management pane.

The following table lists the buttons and their function in the Report Data management pane.

Button Function

Creates report data.
Edi Edits report data.
Deletes report data.

Clones report data.

ol &

Variable Creates a report variable.

Working with Report Data
You can create report data either in:
® Report Wizard in which all data will be saved into an XML file.
® MagicDraw project, in which case the report data will be saved with the project itself. Saving report data in a project will enable you to commit
the report to Teamwork Server.

The following instructions show you how to create and manage your report data in Report Wizard and in a MagicDraw project.

To create report data in Report Wizard

1. Click Tools > Report Wizard.



2. Select a template and click .
3. Click . The New Report Data dialog will appear.
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Creating a Report Data in the New Report Data dialog.
- . Create
4. Enter a new report name and description, and then click .

Before creating report data in a MagicDraw project, you need to use a report profile, Report Profile.mdzip, which is located in the <install.root>\profiles f
older.

To use a report profile (Report Profile.mdzip)

1. On the MagicDraw main menu, click File > Use Project > Use Local Project. The Use Project dialog will open, and the project module path
<install.root>\profiles will be selected by default.
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The Use Local Project menu opens the Use Project dialog that contains a report profile you need before creating a report data in a
MagicDraw project.



Select a project to use

Select a project from the file system or predefined location (paths to used projects) and dick "Next' to proceed.
Predefined locations help finding default application profiles and libraries.
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Selecting a project module path for the report profile and Report Profile.mdzip in the Use Project dialog.
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2. Select Report Profile and click _
3. Specify the usage options.

Specify project usage options
Specify usage options for the selected project and then dick 'Finish' to start using it
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Usage Options.

4. Click . The “Report Profile” profile will open in the Containment tree as a read-only profile. You can now use it in your project



To create a Report Data in a MagicDraw project

1. Use Report Profile.mdzip in your MagicDraw project.
2. Right-click a data model in the Containment tree and select Create Element.
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Creating Report Data in the MagicDraw project
3. Select Report Data from the menu.
4. Type the name of the Report Data element in the Containment tree.

@1 can right-click a data model, a package, or a profile in the Containment tree to create a Report Data.

Tag Values Function
autolmageSize Change the image size.
imageFormat Select an image format, either JPEG or PNG.
emptyText Store a string value that will be replaced with an empty variable.
data Contain elements that will be published by Report Wizard.
template Determine which template to use in a particular Report Data.

generateRecursively = Determine whether or not a report will be generated recursively.

To edit report data



1. Click Tools > Report Wizard.
Mext =

2. Select a template and click .
3. Click . The Edit Report Data dialog will appear.
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Editing a report data in the Edit Report Data dialog
4. Edit the report's name and description, and then click .

To delete report data

1. Click Tools > Report Wizard.

Mext =
2. Select a template and click

3. Click . The Confirm delete dialog will appear.

The Confirm delete dialog.

4. Click either - to delete the selected data or to cancel the operation.

To clone report data

1. Click Tools > Report Wizard.

2. Select a template and click .
—Clme

3. Click . The Clone Report dialog will appear.



Mame

|Co|:ly of My F‘.eport]

Description

My Repart Description

Cloning a report data in the Clone Report dialog.
4. Enter the name and description of the report. The name should begin with Copy of (cloned report name).

Create
5. Click . The cloned Report Data will then be created.

Select a report data

Select a report data (a collection of repaort variables, e.q., Author, Publisher, etc.)
which yau would like to be induded in the generated repart. A built-n report data is
provided for every predefined template.

- Select Report Data
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The Copy of My Report created in the Report Data Management pane.

@en a cloned Report Data is created, a copy of the Report Data (variable) will also be created.

Working with Report Data Variables



Variables are created because some information is not “naturally” contained in a model, e.g. the company's name, author's name, revisions. Although
you can put all of the information in a model's specification (Document/Hyperlinks in the Specification dialog), it is difficult and tedious to get data
from the model's specification, as this results in more lines of codes and scripts in the report templates. Therefore, instead of writing lines of codes,
you can simply create a variable, give it a name, and call it directly from the template. For example, you can create a variable called “Author” in Report

Wizard and write $Author in the template. When you generate the report, you will see the value inside “Author.” Essentially, a variable is used to
represent data that you want to include in the report, not in the model.

Variables contain information that you want to store in a project, such as names and dates. You can create a report variable in a MagicDraw project or
the Report Wizard dialog.

To create a report variable in a MagicDraw project

1. Right-click a Report Data in the Containment tree and select Create Element > Variable. The variable will appear inside the Report Data.
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Creating a variable for Report Data in the Containment tree.

You can also create, edit, and delete variables through the Report Variable dialog in Report Wizard.

To create a report variable in the Report Wizard dialog

1. Open the Rei ort Variable dialog.
2. Click . The New Variable dialog will open. Enter the variable name and description. You can create either a parent variable or

a child variable in the Owner box.



BY Template Variable

Manage report variables

Create, modify, delete variables or set values for them.
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Creating a new variable in the New Variable dialog.

To create a parent variable, type the variable name in the Name box, enter the description, select an empty value in the Owner box, and then
I —Eiltf!

click

B Template Variable .
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Creating MyNewVariableName as a parent variable.



To create a child variable, type the variable name in the Name box, enter the description, select Parent in the Owner box, and then click
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Creating a child variable of MyNewVariableName.

3. The new variable will appear in the table in the Report Variable dialog.

4. Click E to save the variables in the Report Data.

To edit a report variable

1. Open the Report Variable dialog.
2. Double-click on the column next to the variable name column and click [Z] A dialog will open in which you can edit the variable value.



Manage report variables

Create, modify, delete variables or set values for them.
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Editing a variable in the Template Variable dialog

3. Click . The new variable value will appear in the column next to the variable name column.

To delete a report variable

1. Open the Report Variable dialog.
2. Click a variable in the table, and then click Delete. A dialog will open prompting you to confirm before deleting the selected variable.

Dialog to confirm the deletion of a report variable

Yes
3. Click - and the variable will be deleted.

To get the value of a top-level variable

1. Open a blank document in Microsoft Word.
2. Type: $Parent.
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Referencing to a parent variable in the template.

. Open the Report Wizard dialog and click
5. Type the name and description of the new template. Click
Create - [ Mext =

. Click

be shown as in the following figure.

. Save the file as “sampletemplate.rtf’. Choose Rich Text Format (*.rtf) as the file type.

to create a new template. The New Template dialog will open.

to select “sampletemplate.rtf” as the template file.

]. The Select Report Data pane will open.
. Select a report data, in this example, My Report Data and click to generate a report. The output of the generated report will
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V\}hen'\)l/%einclude the variables you have created in a template, each variable value will be included in the generated report. This section will use

the following My Report Data as an example.

To get the value of the child of a variable

1. Open a blank document in Microsoft Word.
2. Type any of the following to print a child variable.

(i) $Parent.get(1) to get a child value by index.

(i) $Parent.get(* Child") to get a child value by name c'\é%ga

I:EI----I:I
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\epork Data
- -Parent = parent valus
b -Child = child value

e (c):)rrt'l Data as an example.

S

(iii) $Parent.Child to get a child value by referencing its name, in this case “Child”.
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Referencing to the child variable in the template

. Save the file as “sampletemplate.rtf”. Choose Rich Text Format (*.rtf) as the file type.

. Open the Report Wizard dialog and click

to create a new template. The New Template dialog will open.

5. Type the name and description of the new template. Click E] to select “sampletemplate.rtf” as the template file.
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The resulting RTF file.

Glossary

® Clone
To clone is to create an exact copy of report data.

* RTF

Rich Text Format (RTF) is a file format developed by Microsoft that can be used with different word processors in different operating systems.

More information about working with reports in Report Wizard

To learn more about reports in Report Wizard, you can visit the following pages:

® Generating Reports from Report Wizard


https://docs.nomagic.com/display/MD190SP2/Generating+Reports+from+Report+Wizard

® Generating Reports from the Containment Tree
® Generating Reports from the Command Line

Sample model
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https://docs.nomagic.com/display/MD190SP2/Generating+reports+from+the+Containment+tree
https://docs.nomagic.com/display/MD190SP2/Generating+reports+from+the+command+line
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