Page tree

Cameo Business Modeler Plugin 2021x Documentation


Cameo Business Modeler plugin for MagicDraw supports BPMN 2.0 model export to XPDL 2.2.

The support for XPDL 2.2 allows you to export your BPMN Processes and Collaborations to XPDL 2.2 format. A separate XPDL file is then created for each exported BPMN Process or Collaboration diagram.

XPDL 2.2 does not support BPMN Choreography and Conversation elements from BPMN Collaborations.



To export multiple BPMN Processes or Collaborations to XPDL


  1. On the main menu, click File> Export To > XPDL File. The Export to XPDL dialog opens.

  2. Select the Selected BPMN Processes/Collaborations option button and choose the diagrams you want to export from the BPMN Processes/Collaborations list.

    Press and hold down the Ctrl key to select multiple BPMN Processes or Collaborations.
  3. Click the ... button next to the Working Directory box to specify the place for saving the exporting project.
  4. Click Save.


To export an active BPMN Process or Collaboration to XPDL


  1. Do one of the following:
    • On the main menu, click File > Export To > XPDL File.
    • Right-click the BPMN Process or Collaboration diagram in the Containment tree and from the shortcut menu, select Tools > Export To XPDL File. The Export to XPDL dialog opens.

  2. Select the Active BPMN Process/Collaboration option button.
  3. Do one of the following:
    • Type the name for a destination directory in the Xpdl File box.
    • Click the ... button next to the Working Directory box to specify the place for saving the exporting project.
  4. Click Save.
  • No labels