Page tree

Cameo Business Modeler Plugin 2021x Refresh1 Documentation


Cameo Business Modeler plugin for MagicDraw supports BPMN model export to BPMN2.

The support allows you to export your BPMN Processes, Collaborations or Choreographies to BPMN2 file.


To export BPMN Processes, Collaborations or Choreographies to BPMN2


  1. On the main menu, click File> Export To > BPMN2 File. The Export to BPMN2 File dialog opens.
  2. Select the Selected BPMN Processes/Collaborations/Choreographies option button and choose the diagrams you want to export from the BPMN Processes/Collaborations list.

    Press and hold down the Ctrl key to select multiple BPMN Processes or Collaborations.
  3. Click the ... button next to the Working Directory box to specify the place for saving the exported file.
  4. Click Save.


To export an active BPMN Process, Collaboration or Choreographies to BPMN2


  1. Do one of the following:
    • On the main menu, click File > Export To > BPMN2 File.
    • Right-click the BPMN Process or Collaboration diagram in the Containment tree and from the shortcut menu, select Tools > Export To BPMN2 File. The Export to BPMN2 dialog opens.
  2. Select the Active BPMN Process/Collaboration/Choreographies option button.
  3. Click the ... button next to the BPMN2 File box to specify the place for saving the exporting project.
  4. Click Save.

BPMN Message export to BPMN2 format is not supported.

  • No labels