Page tree

Cameo Concept Modeler Plugin 19.0 LTR Documentation

Contents


When building a system for a business, there exists a wide variety of methodologies to choose from, as well as numerous existing documents and models across any given enterprise. What should be the starting point of the effort, business concepts, is often lost in overwhelming technical detail. A business concept model, unifying business concepts across a domain, is the basis for a solution to this dilemma.

A concept model represents

  • The concepts and defined relationships in the business, 
  • The real world of the business, not the data used by business systems, 
  • The vocabulary to describe models that explain the way the business is run, and 
  • The domain knowledge of business experts. 

In this Quick Start Guide, you will find instructions on how to

  1. work with your Concept Modeling project,
  2. import Web Ontology Language (OWL) ontologies into your Concept Modeling project,
  3. set up your concept model for export,
  4. export your concept model to an OWL ontology, and
  5. generate a Natural Language Glossary (a document that explains your concept model in plain-English) from your concept model.


Concept Modeling Project

To create a new concept modeling project


  1. Click File > New Project. The New Project dialog appears. 
  2. In the left column, scroll down and select Concept Modeling Project, as shown below.
  3. Name your project and select your Project Location
  4. Click OK

A default Concept Modeling diagram will open, complete with the Concept Modeling diagram palette. 

DiagramPallete.PNG

The Concept Modeling diagram and its palette.


To create a new concept model in your Concept Modeling project


  1. Right-click a package in the Containment tree. 
  2. Select Concept Modeling.
  3. Select Create Concept Model.

You will see your newly created concept model called Unnamed 1. If you create another concept model in the same way, the second concept model will be called Unnamed 2, and so on. 

New concept model called Unnamed 1.


Importing OWL ontologies into your Concept Modeling Project

If you have your ontology ready for import, have it ready on your computer.

To import an OWL ontology into a concept model


  1. On the main menu, click File > Import From. Select OWL Ontology File.
  2. Browse for your OWL ontology.
  3. Click Open. The ontology file will be imported into the Concept Modeling project. 
  4. When the OWL ontology file has been successfully imported, an Imported Ontologies package will appear in the Containment tree. This package contains the imported OWL data. Furthermore, this package also contains the concept model corresponding to the ontology you imported.

The Imported Ontologies package appears in the Containment tree.

Setting up the concept model URI

A Uniform Resource Identifier (URI) is necessary for your concept model in order for it to be exported to an OWL ontology. If you forget to change the default URI, the notification window will open to remind you to change it when you export the concept model to an OWL ontology. If you are unsure of the URI's format, please refer to the following link that describes the IETF URI specification, RFC 2396: http://www.ietf.org/rfc/rfc2396.txt.

The last part of the URI is used as the filename, and the extension for this file will be derived from the export format specified in the project options. 

To set the concept model URI


  1. Right-click on a package, e.g. Example in the Containment tree, and select Specification
  2. In the specification window, find or search for the URI field.
  3. Click the URI field. 
  4. Update the URI.
  5. Click OK.


Exporting your Concept Model to an OWL Ontology

To set the syntax to export your concept model


  1. From the main menu, click Options > Project. The Project Options dialog appears.
  2. In the left column, select General > Concept Modeling.
  3. Click the OWL Export Syntax field. 
  4. Select a syntax to export your concept model.

User Manual Info

Please note that the documentation uses OWL Functional as its OWL export syntax, but you can use any syntax which you prefer.

To select a destination folder for export


  1. From the main menu, click Options > Project. The Project Options dialog opens.
  2. In the left column of the dialog, select General > Concept Modeling.
  3. Select the Always prompt for a file destination when exporting OWL option.
  4. Click OK.

To export a concept model to an OWL ontology


  1. Right-click on your desired concept model in the Containment tree. 
  2. Select Concept Modeling > Export to OWL.
  3. A progress bar will appear.
  4. A dialog will appear asking you to choose the folder into which to save the exported model.
  5. A Path Variables dialog will appear. The default path variable is <project.dir>\OWL. Choose Use Selected.
  6. Your concept model is now exported into the folder of your choice with the file extension of your choice. 


Generating a Natural Language Glossary for your Concept Model

To generate a Natural Language Glossary


  1. In the main menu, select Tools > Report Wizard.
  2. Expand the Concept Modeler folder.
  3. Select Natural Language Glossary.
  4. Click the Next button.
  5. Select Default.
  6. Click Next.
  7. Select the packages for the natural language glossary.
  8. Click Add + button.
  9. Click Next.
  10. Name your file and file location.
  11. Click Generate.



The Natural Language Glossary is generated

If you would like to learn more about how to style and/or populate your Natural Language Glossary, click here.


  • No labels