MagicDraw 19.0 LTR SP1 Documentation


On this page


Need help? Send notifications of a problem, suggest improvements for our modeling tools, or ask about new features directly from the modeling tool. Simply choose Help > Report an Issue from the main menu. If the modeling tool stops responding, you can use the executable tools for analyzing and submitting the status of the process. To report an issue using an executable file, start the reportissue.exe file, located in <modeling tool installation directory>\bin.

These reports help us address issues in a timely manner, as well as speeding up maintenance releases with fixes that are free of known defects.

Automatic Report Build

When reporting an issue directly from the modeling tool, information is automatically incorporated into a report.

File unable to load

If the modeling tool is unable to load your file, and the file is non-confidential, please attach it to your submission. It will assist us when we analyze your issue.


Reporting issues directly from the modeling tool

We strongly recommend submitting a report for any problem, suggestion, or question about new features directly from the modeling tool. Your report will create an issue in our Online Customer Support System.


To report an issue directly from the modeling tool


  1. On the Help menu, click Report an Issue. The Report an Issue dialog opens.
  2. Fill in your first and last name together with your email address.

    Email

    If you supply the email address you used when registering at www.magicdraw.com, you will be able to track the status of your issue in our Online Customer Support System. If you used another email address, you will only receive email notifications of status changes.

  3. Choose the productissue type, and component.
  4. Describe your issue. Please provide as much information as possible.

    Registered MagicDraw Users

    Please note that we provide professional support for registered users with a valid No Magic Software Assurance Contract (SA). SA provides you with technical support, together with major software updates and maintenance releases, at no cost throughout the contract period. Issues are normally handled within one or two business days during regular business hours.

  5. In the Attachments tab, select files you would like to send together with your issue report:

    • Attach log file - the log file will be sent with your issue report.

    • Attach project file - the opened and last saved project file will be sent with your issue report.
    • Attach used projects - modules that have been used in the opened project file will be sent with your issue report. 
    • Attach diagrams images - choose diagrams, whose images you would like to send with your issue report. Also, specify the images format.
  6. If an Out Of Memory error occurs when running the program, you must send the file containing the memory heap size. In the Heap tab, click the Dump Heap button to get the path to the heap file. The path is displayed in the notification message at the bottom of your screen on the right.

    Copying the path to the heap file

    Open the Notification window to copy the path to the heap file. Do one of the following:

    - Click the icon at the right bottom of the program window.

    - On the main menu, click Window > Notification Window.

    - Or press Ctrl+M.

  7. If you are a registered user, track your issue at https://support.nomagic.com

Autofill

If you are already registered, your personal information will be automatically filled in on the Report an Issue dialog. 



Report an issue when the program is unresponsive

If the modeling tool becomes unresponsive, a separately executable tool is provided for analyzing the status of the process to aid in bug submission. In these situations, manually start the submitbug.exe file (located in the <modeling tool installation directory>\bin folder) and follow directions. After you start submitbug.exe, the Report an Issue dialog opens.

Reporting Issues Through Email

The e-mail address for registered users to access our customer support system is support@nomagic.com.

The system allows you to include keywords in the email’s subject line. These keywords will enable us to route the issue to the proper support organization more quickly and resolve the issue in a more timely manner. They also allow definition of many fields for the newly created issue (reporter, project, priority, affected components, affected version).

Support Issues

Support Issues can only be reported or commented on from the email address registered in your www.nomagic.com account.


The parameters are listed below:

  • #PROJECT
  • #SECURITY_LEVEL

Format of the Email

For example, if you have a question about documentation in UPDM, you might submit the following email:

This email sent from the registered user will create a support issue in the UPDM project. The Issue’s component will be Documentation and Requirements Management and its severity will be low.

Parameters

  1. Parameters should be listed in the email subject line with a single space between them.
  2. No commas should be used between parameters.
  3. No spaces should be used in the body of the parameter.
  4. If a parameter value contains spaces, you must replace each space with two underscore characters. For instance, #COMPONENT=Test__Component associates the issue to Test Component. If you specify an invalid component or none at all, the issue is associated to No Component by default.

Emailing support requests can be faster compared to the web interface http://knowledgebase.nomagic.com; however, when reporting issues through email, additional important information might be lost. This information loss can be mitigated by including parameters from the list above.

If an email has email addresses in either the CC: or the BCC: fields, they will be added to the support issue as External Watchers. All watchers receive email notifications about any activity on the issue.

Support Issues

Support issues that are marked private are not viewable within the support system, even if you are listed as an external watcher. Non-registered users also will be unable to see issues within the support system.


Commenting on a Support Issue

To comment on an existing support issue, please reply to the notification email. The body of the email will become your comment on the issue. If you send attachments with your email, they will become attachments on the issue.

Issue ID

It is important that the issue id (e.g. [MDUMLCS-2058]) exists in the subject line.

Not a registered user

If a commenter is not registered in www.nomagic.com, his or her comment is not recorded in the support issue.

View and Submit Internal Errors

Internal errors are displayed as notifications by default. The internal error does not necessarily mean damage to your data, but can be a reason for unexpected tool behavior. We highly recommend submitting internal errors to No Magic for further investigation. You can submit either manually or automatically. In both cases, we strongly recommend attaching the log file. An internal error message appears at the bottom of the modeling tool. 

Example of Internal Error message in MagicDraw modeling tool

To view internal errors


To view internal errors you must open the Internal Errors dialog, using one of the three methods outlined below:

  • Click the View and Submit Internal Errors button in the Notification Window.
  • From the Help main menu, choose the View and Submit Internal Errors command.
  • Click the notification icon on the status bar.

Button Availability

The View and Submit Internal Errors buttons in the Help main menu and the red button at the bottom of the status bar only exist if the Submit Errors dialog actually contains errors.


To submit an error


  1. Open the Internal Errors dialog.
  2. Click the Submit button in the Internal Errors dialog box. The Submit Error dialog appears.
  3. Fill in Your nameYour e-mail and Bug description fields and click the Send button. 

The error will be sent to the support team. Submitted internal errors will not be shown for 24 hours (or until you restart your modeling tool) after clicking the Submit or Clear And Close buttons.


To allow automatic internal errors submission


  1. From Options menu, select Environment. The Environment Options dialog will open.
  2. Click on the General options group Internal Errors.
  3. To allow automatic internal errors submission: in the Internal Errors options list, change the Automatically Submit Internal Errors value to true.

Question dialog

If you set the Automatically Submit Internal Errors value to false in the Environment Options dialog, the Question dialog shown below appears when closing the error notification or before the Internal Errors dialog opens.

  • Select Attach the log file check box to attach the log file for Submitting Internal Errors,
  • To automatically submit internal errors to No Magic, click Yes.



To attach the log file when automatically submitting Internal Errors to No Magic


  1. From the Options menu, select Environment. The Environment options dialog will open.
    In the General options group, click Internal Errors.
  2. To attach the log file, in the Internal Errors options list, change the Attach Log File Submitting Internal Errors option value to true.


To Display Internal Errors


  1. From the Options menu, select Environment. The Environment options dialog will open.
  2. In the General options group, click Internal Errors.
  3. In the Internal Errors options list change the Display Internal Errors option value to true to display internal errors.

Background Task Manager

You can see the submitted internal errors status in the Background Task Manager at the bottom right corner of the modeling tool window. Click the Background tasks icon to see the status.

  • During the submission process, the status will be submitting.
  • If the submission process was successful, the status will be submitted automatically.
  • If the submission process failed, the status will be automatic submission failed, and the automatic submission will resubmit errors a maximum of 5 times (every 10 minutes). Otherwise, you can submit internal errors manually using the dialog Report an Issue.
  • No labels