Page tree

MagicDraw 19.0 LTR SP2 Documentation

Contents


On this page

You must lock the part of the model you are going to edit to prevent other users from editing it at the same time. Locking is allowed if that part of the model is not locked by another user, because the same item can only be locked by  one user at a time. 

The following table explains what you can edit after you lock a single element, single diagram, diagram with elements, and so on.

When you lock...You can...
ElementEdit element specification properties (in the Specification window)
Diagram

Edit:

  • Diagram specification properties (in the Specification window)
  • Diagram properties (in the Diagram Properties dialog)
  • Symbol layout on the diagram pane
  • Symbol properties (in the Symbol Properties dialog)
Diagram with elements

Edit:

  • Diagram specification properties (in the Specification window)
  • Element specification properties (in the Specification window and on the diagram pane)
  • Diagram properties (in the Symbol Properties dialog)
  • Symbol properties (in the Symbol Properties dialog)
  • Symbol layout on the diagram pane
Symbol styles

Edit properties of symbol styles (in the Project Options dialog)

Project usages
  • Import used projects as packages into the main project
  • Stop using projects
  • Change versions of used projects

Locking without forced project update

You can lock elements without forcing an update of a project to the latest version if the selected elements are not locked or do not have changes in a newer version on the server.

This feature can be disabled/enabled in the Environment Options dialog.

To disable/enable locking without updating


  1. Select Options > Environment > Collaboration node.
  2. Find Enable Locking Without Forced Project Update option. Do one of the following: 
    • Set value to true, to enable locking without updating;
    • Set value to false, to disable locking without updating

There is a 60-second threshold; if locking takes longer than 60 seconds, a project update will be required.

An example

You are trying to lock package B, which contains many elements, recursively. The modeling tool cannot check all contained elements' status in the later versions of the project in 60 seconds. After 60 seconds, a project update will be required to lock the package.

Representation of locked elements

In the Containment tree, element names are represented in two colors:

  • Unlocked elements are represented in black, meaning they are editable.
  • Locked elements are represented in gray, meaning they are not editable.

Locked and unlocked elements in the Containment tree

Locking elements and diagrams

Elements and diagrams can be locked by using the commands from their shortcut menu.

Locking commands on the shortcut menu of the Package


Elements can also be locked by clicking the Lock element for the Edit button  on their Specification window.

Locking command in the element's Specification window


The following table provides suggestions on which locking commands to use for different purposes.

If you need to edit...Do the following

Specification properties of a single element

  1. Right-click either:
    • This element in the Model Browser.
    • A symbol of this element on a diagram pane.
  2. From the shortcut menu, select Lock > Lock Element for Edit.

OR

  1. Double-click either:
    • This element in the Model Browser.
    • A symbol of this element on a diagram pane.
  2. In the Specification window, click the Lock element for Edit button Lock element for Edit.

Specification properties of both an element and the elements it contains (owns)

For example, a project has a Package Analysis, containing two inner Packages
- Design and Implementation. Each inner Package also contains elements.

Lock the Package Analysis recursively to edit all the elements in this Package.


  1. Right-click either:
    • This element in the Model Browser.
    • A symbol of this element on a diagram pane.
  2. From the shortcut menu, select Lock > Lock Elements for Edit Recursively

At least one of the following:

  • Diagram representation properties (including diagram layout)
  • Symbol properties of elements represented on that diagram pane
  1. Right-click this diagram in the Model Browser.
  2. From the shortcut menu, select Lock > Lock Diagram for Edit.

OR

  1. Right-click a free space on this diagram pane.
  2. From the shortcut menu, select Lock Diagram > Lock Diagram for Edit.

At least one of the following:

  • Diagram specification properties
  • Diagram representation properties (including diagram layout)
  • Properties of elements represented on that diagram pane
  • Symbol properties of elements represented on that diagram pane
  1. Right-click this diagram in the Model Browser.
  2. From the shortcut menu, select Lock > Lock Diagram Content for Edit.

OR

  1. Right-click a free space on this diagram pane.
  2. From the shortcut menu, select Lock Diagram > Lock Diagram Content for Edit.

At least one of the following:

  • Symbol properties of a single element represented on a diagram pane

  • Position of the symbol on the diagram pane
  1. Right-click the symbol of that element on a diagram pane.
  2. From the shortcut menu, select Lock > Lock Element for Edit in Diagram.

Locking symbol styles

You can lock symbol styles via the Lock View tab or the Project Options dialog.


To lock symbol styles via the Lock View tab


  1. In the Lock View tab on the Model Browser, expand Project Options.

     Where is the Lock View tab?
    It is the last tab on the Model Browser. If the tab is closed, you can simply open it by selecting Collaborate > View Locked Elements.
  2. Right-click Symbol Styles and from the shortcut menu select Lock Symbol Styles for Edit.


To lock symbol styles via the Project Options dialog


  1. Do either:
    • Select Options > Project.
    • In the Lock View tab on the Model Browser, right-click Project Options and from the shortcut menu, select Symbol Styles.

       Where is the Lock View tab?
      It is the last tab on the Model Browser. If the tab is closed, you can simply open it by selecting Collaborate > View Locked Elements.
  2. In the Project Options dialog, click the Lock Symbol Styles for Edit button.


Locking symbol styles via the Project Options dialog


As a result, symbol styles become editable. Additionally, the Make Default button (1) in all Symbol Properties dialogs and the Set Selected Symbol Style as Default button (2) on all the diagram toolbars become available.

Symbol style manipulation buttons

Locking project usages

To lock a used project


  1. From the Options menu, select Project Usages. The Project Usages dialog opens.
  2. Select a used project on the left side of the dialog.

  3. Click the Edit button and then select Lock.


You can then import this used project as a package to the main project, stop using it, or change its version.

  • No labels