Page tree

MagicDraw 19.0 LTR SP3 Documentation


Modeling tools support all common copying/cutting and pasting functions, as well as advanced copying and pasting functions. You can copy and paste objects from one project to another. You can find these options in the Edit menu.

Advanced commands for copying:

CommandShortcutDescription

WindowsMac OS
Copy URL

Copies the URL of the selected project element or element symbol to the clipboard (the project element and the element symbol have different URLs). To copy the URL of an element, select Copy URL from the element shortcut menu in the Containment tree. To copy the URL of an element symbol, select the the symbol and click Edit > Copy URL.

You can use URLs to open any elements by clicking the Open Element from URL command. The element is then highlighted in the Containment tree or in a diagram. Activating the URL in another application allows you to start MagicDraw, open a project (if possible), and select any elements. You can paste URLs from the clipboard to any MagicDraw diagram. Hyperlinks can also hold URLs of any model elements.

Copy as BMP ImageCtrl+Shift+B⇧B

Copies the selected shapes to the clipboard. If no shapes are selected, the active diagram is copied. The .bmp image format provides the best image quality. The image files of this format are typically not compressed, resulting in a large file.

Copy as EMF ImageCtrl+Shift+E⇧E

Copies the selected shapes to the clipboard. If no shapes are selected, the active diagram is copied. The .emf format image files are smaller, so using this format reduces network traffic. Additionally, the .emf format supports language specific symbols.

EMF does not support gradient fill. Because icons of the modeling tool are stored in the SVG format, it may be exported incorrectly.

To render SVG icons as raster images in EMF, on the main menu, click Options > Environment > General > Image Export and set the Render SVG Icons as Raster Images in EMF option to true.


Copy as JPG ImageCtrl+Shift+J⇧J

Copies the selected shapes to the clipboard. If no shapes are selected, the active diagram is copied. The .jpg format produces relatively small file sizes, but when compressing, the .jpg image file loses data, which results in lower quality. Thus, this format is suitable for final distribution of images, but is not recommended if images are to be edited.

Copy as PNG ImageCtrl+Shift+P⇧P

Copies the selected shapes to the clipboard. If no shapes are selected, the active diagram is copied. The .png format is best suited for storing images during the editing process because of its lossless compression. Compared to the .jpg format, the .png excels when the image has large areas of uniform color. It also works well in online viewing applications, such as web browsers.



Advanced commands for pasting:

CommandShortcutDescription

WindowsMac OS
Paste with New DataCtrl+E⌘E

Pastes one or more copied model elements by creating new model elements. Use this command when copying or cutting owned symbols from one shape to another in a diagram.

Paste StyleCtrl+Shift+V⇧VPastes symbol properties to the selected symbol. You can copy and paste symbol properties of more than one symbol at the same time. Symbol properties are pasted according to the element type. For example, on a class symbol, the class symbol properties are pasted, and on a package symbol, the package symbol properties are pasted, etc.
Paste as Diagram Overview

Creates a new diagram overview representing selected elements. A diagram overview shape provides the ability to overview other diagrams on a diagram pane. Moreover, using diagram overview shape you can overview dependency matrices, tables, and relation maps.

In addition to the described commands, there you have the ability to copy the whole diagram or the selected shapes and paste them to Microsoft Office or other applications.

Not all symbols can be copied/cut and pasted.

  • No labels