Page tree

MagicDraw 19.0 LTR SP4 Documentation


MagicDraw allows exporting projects to the following file formats:

  • UML XMI 2.5 file. You can export a project to file formats that are supported by MagicDraw.
  • MagicDraw Native XML file. You can export a project to an .xml file format.
  • EMF Ecore file. You can export either the whole project or selected packages to an .ecore file.
  • MOF XMI file. You can export a project to an MOF (both CMOF and EMOF) XMI file.
  • Eclipse UML2 (v1.x, v2.x, v3.x, v4.x, v5.x) XMI file. You can export a project to an Eclipse based UML2 (v1.x / v2.x / v3.x / v4.x / v5.x) compatible XMI file.

To export a project


  1. On the main menu, click File > Export To. 
  2. Select a file format you want to export your project to. 
  3. The following actions depend on the dialog that corresponds to the selected file format.

Exporting projects as Eclipse UML2 (v1.x / v2.x / v3.x / v4.x / v5.x) XMI files

The export of a MagicDraw model to an Eclipse based UML2 (v1.x / v2.x / v3.x / v4.x / v5.x) compatible XMI file enables the interchange of the UML2 models for further manipulations and transformations with the most popular MDA tools. You can also export your project as a template.


To export a project as an Eclipse UML2 (v1.x / v2.x / v3.x / v4.x / v5.x) XMI file


  1. Open a project you want to export as an Eclipse UML2 (v1.x / v2.x / v3.x / v4.x / v5.x) XMI file.
  2. On the File menu, click Export To and select one of the following command: 
    • Eclipse UML2 (v1.x) XMI file.
    • Eclipse UML2 (v2.x) XMI file.
    • Eclipse UML2 (v3.x) XMI file.
    • Eclipse UML2 (v4.x) XMI file 
    • Eclipse UML2 (v5.x) XMI file 
  3. Specify a location for exported project files. 
  4. Click Export.

  • A project exported as an Eclipse UML2 (v1.x) XMI file is saved with the .uml2 file extension.
  • A project exported as an Eclipse UML2 (v2.x / v3.x / v4.x / v5.x) XMI file is saved with the .uml file extension.


To change export property values


  1. From the Options menu, select Environment.
  2. Click one of the following options group:

    • Eclipse UML2 (v1.x) XMI file.
    • Eclipse UML2 (v2.x) XMI file.
    • Eclipse UML2 (v3.x) XMI file. 
    • Eclipse UML2 (v4.x) XMI file.
    • Eclipse UML2 (v5.x) XMI file 

  3. In the property list, specify the desired property values. You can see descriptions of each property in the description area below the property list.